summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJohn Khvatov <ivaxer@fedoraproject.org>2014-05-01 00:57:04 +0400
committerJohn Khvatov <ivaxer@fedoraproject.org>2014-05-01 04:11:54 +0400
commit55490439d00273a7ae09e0d45095ef453a987fd7 (patch)
tree226383e30ff18c51f9a4771af8d5599ed6133bde /CMakeLists.txt
parentdc2b2c7fec09b821186606176c061a201b4c0f82 (diff)
downloadgflags-55490439d00273a7ae09e0d45095ef453a987fd7.tar.gz
gflags-55490439d00273a7ae09e0d45095ef453a987fd7.tar.bz2
gflags-55490439d00273a7ae09e0d45095ef453a987fd7.zip
cmake: append LIB_SUFFIX to LIBRARY_INSTALL_DIR
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 17d38b4..10c9cca 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -280,9 +280,9 @@ if (OS_WINDOWS)
set (CONFIG_INSTALL_DIR CMake)
else ()
set (RUNTIME_INSTALL_DIR bin)
- set (LIBRARY_INSTALL_DIR lib)
+ set (LIBRARY_INSTALL_DIR lib${LIB_SUFFIX})
set (INCLUDE_INSTALL_DIR include)
- set (CONFIG_INSTALL_DIR lib/cmake/${PACKAGE_NAME})
+ set (CONFIG_INSTALL_DIR lib${LIB_SUFFIX}/cmake/${PACKAGE_NAME})
endif ()
file (RELATIVE_PATH INSTALL_PREFIX_REL2CONFIG_DIR "${CMAKE_INSTALL_PREFIX}/${CONFIG_INSTALL_DIR}" "${CMAKE_INSTALL_PREFIX}")