summaryrefslogtreecommitdiff
path: root/src/Makefile.am
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-11-04 20:48:06 -0800
committerAnas Nashif <anas.nashif@intel.com>2012-11-04 20:48:06 -0800
commit2a5aa8c2d96550c8463ef3714a20b46397f58b52 (patch)
tree013f2f8a08267abbe27f2cc8f576622b4fbc879d /src/Makefile.am
downloadgdbm-2a5aa8c2d96550c8463ef3714a20b46397f58b52.tar.gz
gdbm-2a5aa8c2d96550c8463ef3714a20b46397f58b52.tar.bz2
gdbm-2a5aa8c2d96550c8463ef3714a20b46397f58b52.zip
Imported Upstream version 1.10upstream/1.10
Diffstat (limited to 'src/Makefile.am')
-rw-r--r--src/Makefile.am67
1 files changed, 67 insertions, 0 deletions
diff --git a/src/Makefile.am b/src/Makefile.am
new file mode 100644
index 0000000..1c55a4e
--- /dev/null
+++ b/src/Makefile.am
@@ -0,0 +1,67 @@
+# This file is part of GDBM. -*- Makefile -*-
+# Copyright (C) 2007, 2011 Free Software Foundation, Inc.
+#
+# GDBM is free software; you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation; either version 3, or (at your option)
+# any later version.
+#
+# GDBM is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with GDBM. If not, see <http://www.gnu.org/licenses/>.
+
+# Flags
+AM_CPPFLAGS=-DIN_GDBM -DLOCALEDIR=\"$(localedir)\"
+
+# Headers
+include_HEADERS = gdbm.h
+noinst_HEADERS = \
+ gdbmconst.h\
+ gdbmdefs.h\
+ gettext.h\
+ proto.h\
+ systems.h
+
+EXTRA_DIST = gdbm.h.in
+
+# The libraries
+VI_CURRENT = 4
+VI_REVISION = 0
+VI_AGE = 0
+
+lib_LTLIBRARIES = libgdbm.la
+libgdbm_la_LIBADD = @LTLIBINTL@
+
+libgdbm_la_SOURCES = \
+ gdbmopen.c\
+ gdbmdelete.c\
+ gdbmfetch.c\
+ gdbmstore.c\
+ gdbmclose.c\
+ gdbmreorg.c\
+ gdbmseq.c\
+ gdbmsync.c\
+ gdbmerrno.c\
+ gdbmexists.c\
+ gdbmfdesc.c\
+ gdbmsetopt.c\
+ bucket.c\
+ falloc.c\
+ findkey.c\
+ flatfile.c\
+ fullio.c\
+ hash.c\
+ lock.c\
+ mmap.c\
+ update.c\
+ version.c
+
+libgdbm_la_LDFLAGS = -version-info $(VI_CURRENT):$(VI_REVISION):$(VI_AGE)
+
+# Programs
+bin_PROGRAMS = testgdbm
+testgdbm_LDADD = ./libgdbm.la