summaryrefslogtreecommitdiff
path: root/test/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'test/Makefile.am')
-rw-r--r--test/Makefile.am6
1 files changed, 5 insertions, 1 deletions
diff --git a/test/Makefile.am b/test/Makefile.am
index ea7ac77..9224152 100644
--- a/test/Makefile.am
+++ b/test/Makefile.am
@@ -1,4 +1,6 @@
+SUBDIRS = unicode-conformance
+
TESTS_ENVIRONMENT = \
srcdir=${srcdir}; export srcdir; \
top_builddir=${top_builddir}; export top_builddir; \
@@ -27,7 +29,9 @@ EXTRA_DIST = \
$(TESTS) \
$(TEST_DATAS)
-test_%.reference: test_%.input
+SUFFIXES: .reference .input
+
+.reference.input:
testcase="$@" && \
charset="`echo "$@" | sed 's/_[^_]*$$//;s/.*_//'`" && \
$(top_builddir)/bin/fribidi --test --charset "$$charset" "$<" > "$@" \