summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am30
1 files changed, 19 insertions, 11 deletions
diff --git a/Makefile.am b/Makefile.am
index 5bad607..63e5e65 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -66,6 +66,9 @@ flex_SOURCES = \
filter.c \
regex.c
+
+LDADD = lib/libcompat.a
+
libfl_a_SOURCES = \
libmain.c \
libyywrap.c
@@ -90,21 +93,22 @@ noinst_HEADERS = \
include_HEADERS = \
FlexLexer.h
-EXTRA_DIST = \
- .indent.pro \
+dist_doc_DATA = \
AUTHORS \
COPYING \
- INSTALL \
NEWS \
ONEWS \
README \
README.cvs \
- THANKS \
- TODO \
+ TODO
+
+EXTRA_DIST = \
+ .indent.pro \
+ ABOUT-NLS \
+ INSTALL \
autogen.sh \
flex.skl \
mkskel.sh \
- ABOUT-NLS \
config.rpath \
gettext.h
@@ -112,9 +116,9 @@ BUILT_SOURCES = \
skel.c
SUBDIRS = \
+ lib \
. \
doc \
- m4 \
examples \
po \
tools \
@@ -154,11 +158,11 @@ tblcmp.o: tblcmp.c flexdef.h flexint.h
yylex.o: yylex.c flexdef.h flexint.h parse.h
filter.o: filter.c flexdef.h flexint.h
-# Create the ChangeLog, but only if we're inside a cvs working directory
+# Create the ChangeLog, but only if we're inside a git working directory
-ChangeLog: $(srcdir)/tools/cvsauthors $(srcdir)/tools/cvs2cl.pl
- if [ -d CVS ] ; then \
- sh $(srcdir)/tools/cvs2cl.pl -F trunk -U $(srcdir)/tools/cvsauthors \
+ChangeLog: $(srcdir)/tools/git2cl
+ if [ -d $(srcdir)/.git ] ; then \
+ $(srcdir)/tools/git2cl > $@ \
; fi
# Run GNU indent on sources. Don't run this unless all the sources compile cleanly.
@@ -205,4 +209,8 @@ indent:
done \
fi
+install-exec-hook:
+ cd $(DESTDIR)/$(bindir) && \
+ $(LN_S) -f flex$(EXEEXT) flex++$(EXEEXT)
+
.PHONY: ChangeLog tags indent