summaryrefslogtreecommitdiff
path: root/packaging/flex.spec
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-11-04 18:16:57 -0800
committerAnas Nashif <anas.nashif@intel.com>2012-11-04 18:16:57 -0800
commit0960e23e38178233fc295c3d87760f6f8fac58bf (patch)
tree5c65b4816581732cc8db33152aad1eb0546d7efa /packaging/flex.spec
parentc29d6e204b4dfe99a2f08c258652823e4c26c324 (diff)
downloadflex-0960e23e38178233fc295c3d87760f6f8fac58bf.tar.gz
flex-0960e23e38178233fc295c3d87760f6f8fac58bf.tar.bz2
flex-0960e23e38178233fc295c3d87760f6f8fac58bf.zip
add packaging
Diffstat (limited to 'packaging/flex.spec')
-rw-r--r--packaging/flex.spec62
1 files changed, 62 insertions, 0 deletions
diff --git a/packaging/flex.spec b/packaging/flex.spec
new file mode 100644
index 0000000..cbe6263
--- /dev/null
+++ b/packaging/flex.spec
@@ -0,0 +1,62 @@
+Name: flex
+Version: 2.5.35
+Release: 0
+License: BSD-3-Clause
+Summary: Fast Lexical Analyzer Generator
+Url: http://flex.sourceforge.net/
+Group: Development/Languages/C and C++
+Source: %{name}-%{version}.tar.bz2
+Source1: lex-wrapper.sh
+Source3: baselibs.conf
+Patch1: flex-2.5.34-fPIC.patch
+Patch2: flex-2.5.33-yylineno.patch
+Patch3: flex-2.5.34-doc-fix.diff
+Patch4: flex-2.5.34-g++44.diff
+Patch5: flex-2.5.34-asneeded.patch
+BuildRequires: automake
+BuildRequires: bison
+BuildRequires: gcc-c++
+BuildRequires: gettext-tools
+Requires: m4
+
+%description
+FLEX is a tool for generating scanners: programs that recognize lexical
+patterns in text.
+
+%prep
+%setup -q
+%patch1
+# Patch2 disabled for now, as the testsuite explicitly tests for yylineno in
+# all scanners. Let's see if the failing packages got fixed in the meantime.
+#patch2
+%patch3
+%patch4
+%patch5
+
+%build
+autoreconf -fi
+%configure --disable-nls
+make %{?_smp_mflags}
+
+%check
+%if !0%{?qemu_user_space_build:1}
+make check
+%endif
+
+%install
+%make_install
+install %{SOURCE1} %{buildroot}/%{_bindir}/lex
+ln -s flex %{buildroot}/%{_bindir}/flex++
+ln -s flex.1.gz %{buildroot}/%{_mandir}/man1/lex.1.gz
+
+%files
+%defattr(-,root,root)
+/usr/bin/flex
+/usr/bin/flex++
+/usr/bin/lex
+/usr/include/FlexLexer.h
+%{_libdir}/libfl.a
+%{_mandir}/man1/flex.1.gz
+%{_mandir}/man1/lex.1.gz
+%{_infodir}/flex*
+