summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorWouter van Oortmerssen <aardappel@gmail.com>2020-08-18 14:00:22 -0700
committerWouter van Oortmerssen <aardappel@gmail.com>2020-08-18 14:00:22 -0700
commitd713a00843bc4b62bf470db017e87caeda0fff1c (patch)
treee207bb2b714cb5f6aeaa7fa67b4879c2bb7ed409 /CMakeLists.txt
parent77f966f89fcf76fa67485adf941ac6e90d28029c (diff)
downloadflatbuffers-d713a00843bc4b62bf470db017e87caeda0fff1c.tar.gz
flatbuffers-d713a00843bc4b62bf470db017e87caeda0fff1c.tar.bz2
flatbuffers-d713a00843bc4b62bf470db017e87caeda0fff1c.zip
[CMake] enabled multi-core builds in VS projects
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 15251152..9201d679 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -273,6 +273,9 @@ elseif(MSVC)
# warning C4512: assignment operator could not be generated
# warning C4316: object allocated on the heap may not be aligned
set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} /W4 /WX /wd4512 /wd4316")
+
+ # multi-core build.
+ add_definitions("/MP")
endif()
if(FLATBUFFERS_CODE_COVERAGE)