summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDerek Bailey <derekbailey@google.com>2021-11-23 22:32:06 -0800
committerGitHub <noreply@github.com>2021-11-23 22:32:06 -0800
commitc05f6783a6fdec4e9e401144c5f83adfeb4f320d (patch)
treeb965e2f6b5a693c6e64c53c5cae0b6bd4eb363af /CMakeLists.txt
parenta14f4052cfd746093cf4266f681d489f03e13399 (diff)
downloadflatbuffers-c05f6783a6fdec4e9e401144c5f83adfeb4f320d.tar.gz
flatbuffers-c05f6783a6fdec4e9e401144c5f83adfeb4f320d.tar.bz2
flatbuffers-c05f6783a6fdec4e9e401144c5f83adfeb4f320d.zip
invalid conditional running genrate_code.py (#6952)
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 6f5f465a..544c7afb 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -512,7 +512,7 @@ find_package(PythonInterp 3)
if(PYTHONINTERP_FOUND AND
# Skip doing this if the MSVC version is below VS 12.
# https://cmake.org/cmake/help/latest/variable/MSVC_VERSION.html
- (WIN32 AND MSVC_VERSION GREATER 1800))
+ (NOT MSVC OR MSVC_VERSION GREATER 1800))
if(WIN32)
set(GENERATION_SCRIPT py scripts/generate_code.py)
else()
@@ -523,7 +523,7 @@ if(PYTHONINTERP_FOUND AND
POST_BUILD
COMMAND ${GENERATION_SCRIPT} "${FLATBUFFERS_FLATC_EXECUTABLE}"
WORKING_DIRECTORY "${CMAKE_CURRENT_SOURCE_DIR}"
- COMMENT "Generating code..."
+ COMMENT "Running ${GENERATION_SCRIPT}..."
VERBATIM)
endif()