summaryrefslogtreecommitdiff
path: root/src/tcbdb/tools/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/tcbdb/tools/CMakeLists.txt')
-rw-r--r--src/tcbdb/tools/CMakeLists.txt3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/tcbdb/tools/CMakeLists.txt b/src/tcbdb/tools/CMakeLists.txt
index fc1b2bd..b24f0f5 100644
--- a/src/tcbdb/tools/CMakeLists.txt
+++ b/src/tcbdb/tools/CMakeLists.txt
@@ -2,7 +2,8 @@ link_libraries(ejdb_p)
add_executable(jbbmgr jbbmgr.c)
set_target_properties(jbbmgr PROPERTIES
- COMPILE_FLAGS "-DEJDB_STATIC")
+ LINK_FLAGS "-Wl,--as-needed -pie"
+ COMPILE_FLAGS "-DEJDB_STATIC -fPIE")
install(TARGETS jbbmgr