summaryrefslogtreecommitdiff
path: root/tests/userspace/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'tests/userspace/Makefile.am')
-rw-r--r--tests/userspace/Makefile.am26
1 files changed, 26 insertions, 0 deletions
diff --git a/tests/userspace/Makefile.am b/tests/userspace/Makefile.am
new file mode 100644
index 0000000..5f61d5a
--- /dev/null
+++ b/tests/userspace/Makefile.am
@@ -0,0 +1,26 @@
+AUTOMAKE_OPTIONS = subdir-objects
+
+# Only place tests worth of 'make check' here. All other tests are noinst.
+dist_check_SCRIPTS = lfs.sh verify-passphrase-sig.sh
+check_PROGRAMS = lfs/test verify-passphrase-sig/test
+
+dist_noinst_DATA = tests.rc
+
+dist_noinst_SCRIPTS = $(dist_check_SCRIPTS) \
+ wrap-unwrap.sh
+
+if ENABLE_TESTS
+noinst_PROGRAMS = $(check_PROGRAMS) \
+ wrap-unwrap/test
+endif
+
+lfs_test_SOURCES = lfs/test.c
+
+verify_passphrase_sig_test_SOURCES = verify-passphrase-sig/test.c
+verify_passphrase_sig_test_LDADD = $(top_builddir)/src/libecryptfs/libecryptfs.la
+
+wrap_unwrap_test_SOURCES = wrap-unwrap/test.c
+wrap_unwrap_test_LDADD = $(top_builddir)/src/libecryptfs/libecryptfs.la
+
+TESTS = lfs.sh verify-passphrase-sig.sh
+