summaryrefslogtreecommitdiff
path: root/dracut.spec
diff options
context:
space:
mode:
authorHarald Hoyer <harald@redhat.com>2013-03-20 07:15:04 +0100
committerHarald Hoyer <harald@redhat.com>2013-03-20 07:15:04 +0100
commit8c67d395d42b4e34c10418aa6c167122a72a951b (patch)
treef14ccae41eed3c19485da2bcb96025838f4836ed /dracut.spec
parent02566acdd7a3e371d413c30d7267fde2fb01c9cf (diff)
downloaddracut-8c67d395d42b4e34c10418aa6c167122a72a951b.tar.gz
dracut-8c67d395d42b4e34c10418aa6c167122a72a951b.tar.bz2
dracut-8c67d395d42b4e34c10418aa6c167122a72a951b.zip
dracut.spec: use pkg-config for bashcompletiondir
Diffstat (limited to 'dracut.spec')
-rw-r--r--dracut.spec5
1 files changed, 4 insertions, 1 deletions
diff --git a/dracut.spec b/dracut.spec
index 445463f9..cd61770f 100644
--- a/dracut.spec
+++ b/dracut.spec
@@ -34,6 +34,8 @@ BuildRequires: dash bash git
%if 0%{?fedora} || 0%{?rhel}
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
+BuildRequires: bash-completion
+BuildRequires: pkgconfig
%endif
%if 0%{?suse_version}
BuildRoot: %{_tmppath}/%{name}-%{version}-build
@@ -204,7 +206,8 @@ make install DESTDIR=$RPM_BUILD_ROOT \
%if %{defined _unitdir}
systemdsystemunitdir=%{_unitdir} \
%endif
- sysconfdir=/etc mandir=%{_mandir}
+ sysconfdir=/etc mandir=%{_mandir} \
+ bashcompletiondir=$(pkg-config --variable=completionsdir bash-completion)
echo "DRACUT_VERSION=%{version}-%{release}" > $RPM_BUILD_ROOT/%{dracutlibdir}/dracut-version.sh