summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorAnas Nashif <anas.nashif@intel.com>2012-11-06 22:51:15 -0800
committerAnas Nashif <anas.nashif@intel.com>2012-11-06 22:51:15 -0800
commit20c6d7ec2c817aa561410130efc8c8254fbef2b2 (patch)
tree7fedf733ccf6f9ff3ee00913c4fc07110f4a7ba9 /Makefile.am
downloaddiffutils-20c6d7ec2c817aa561410130efc8c8254fbef2b2.tar.gz
diffutils-20c6d7ec2c817aa561410130efc8c8254fbef2b2.tar.bz2
diffutils-20c6d7ec2c817aa561410130efc8c8254fbef2b2.zip
Imported Upstream version 3.2upstream/3.2
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am43
1 files changed, 43 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
new file mode 100644
index 0000000..fbb0b37
--- /dev/null
+++ b/Makefile.am
@@ -0,0 +1,43 @@
+# Main Automakefile for GNU diffutils.
+
+# Copyright (C) 2001-2002, 2004, 2006, 2009-2011 Free Software Foundation, Inc.
+
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+
+ALL_RECURSIVE_TARGETS =
+
+EXTRA_DIST = bootstrap exgettext ChangeLog-2008 cfg.mk dist-check.mk
+SUBDIRS = lib src tests doc man po ms gnulib-tests
+
+ACLOCAL_AMFLAGS = -I m4
+AM_CFLAGS = $(WARN_CFLAGS) $(WERROR_CFLAGS)
+
+# Arrange so that .tarball-version appears only in the distribution
+# tarball, and never in a checked-out repository.
+dist-hook: gen-ChangeLog
+ $(AM_V_GEN)echo $(VERSION) > $(distdir)/.tarball-version
+
+gen_start_date = '2009-11-11 15:00'
+.PHONY: gen-ChangeLog
+gen-ChangeLog:
+ $(AM_V_GEN)if test -d .git; then \
+ $(top_srcdir)/build-aux/gitlog-to-changelog \
+ --since=$(gen_start_date) > $(distdir)/cl-t; \
+ rm -f $(distdir)/ChangeLog; \
+ mv $(distdir)/cl-t $(distdir)/ChangeLog; \
+ fi
+
+ALL_RECURSIVE_TARGETS += distcheck-hook
+distcheck-hook:
+ $(MAKE) my-distcheck