summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorYaakov Selkowitz <yselkowitz@users.sourceforge.net>2010-08-09 08:32:04 +0200
committerRalf Habacker <ralf.habacker@freenet.de>2010-08-10 08:25:24 +0200
commitaec82e2edd6344310958e9b038a4bb17bcbba5b7 (patch)
treee37a17fc6b270855193e1f24ca3948ce838b8673 /configure.in
parent77ee59e06dbb6facda9d4ebdcf47f14adfea091e (diff)
downloaddbus-aec82e2edd6344310958e9b038a4bb17bcbba5b7.tar.gz
dbus-aec82e2edd6344310958e9b038a4bb17bcbba5b7.tar.bz2
dbus-aec82e2edd6344310958e9b038a4bb17bcbba5b7.zip
Applied patches from cygwin port.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in21
1 files changed, 11 insertions, 10 deletions
diff --git a/configure.in b/configure.in
index 648b1155..5a386413 100644
--- a/configure.in
+++ b/configure.in
@@ -1356,23 +1356,24 @@ if test -f /etc/slackware-version || test -f $EXPANDED_SYSCONFDIR/slackware-vers
operating_system=slackware
fi
+if test -f /usr/bin/cygwin1.dll || test -f $EXPANDED_BINDIR/cygwin1.dll ; then
+ operating_system=cygwin
+fi
+
#### Sort out init scripts
if test x$with_init_scripts = x; then
- if test xredhat = x$operating_system ; then
- with_init_scripts=redhat
- else
- if test xslackware = x$operating_system ; then
- with_init_scripts=slackware
- else
- with_init_scripts=none
- fi
- fi
+ case x$operating_system in
+ xredhat) with_init_scripts=redhat ;;
+ xslackware) with_init_scripts=slackware ;;
+ xcygwin) with_init_scripts=cygwin ;;
+ *) with_init_scripts=none ;;
+ esac
fi
AM_CONDITIONAL(DBUS_INIT_SCRIPTS_RED_HAT, test x$with_init_scripts = xredhat)
-
AM_CONDITIONAL(DBUS_INIT_SCRIPTS_SLACKWARE, test x$with_init_scripts = xslackware)
+AM_CONDITIONAL(DBUS_INIT_SCRIPTS_CYGWIN, test x$with_init_scripts = xcygwin)
##### systemd unit files
AC_ARG_WITH([systemdsystemunitdir],