summaryrefslogtreecommitdiff
path: root/configure.in
diff options
context:
space:
mode:
authorLennart Poettering <lennart@poettering.net>2011-02-15 13:29:28 +0100
committerLennart Poettering <lennart@poettering.net>2011-02-15 13:29:31 +0100
commit509a2e899a73a40fab42021ca51f1b9424c61586 (patch)
tree7abbd9c3ed65d6488a4b36c0f12954f6df5343a4 /configure.in
parent51e0e91115e54cb29aca515d2e920a67d1c7fca5 (diff)
downloaddbus-509a2e899a73a40fab42021ca51f1b9424c61586.tar.gz
dbus-509a2e899a73a40fab42021ca51f1b9424c61586.tar.bz2
dbus-509a2e899a73a40fab42021ca51f1b9424c61586.zip
build-sys: ignore -Waddress message so that build works on gcc/rawhide
Newer gccs warn if you compare an address of a variable that is allocated on the stack or is static with NULL. Since we compile dbus with -Werror this causes the build to fail since we do this check all the time due to macros such as _DBUS_ASSERT_ERROR_IS_SET().
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in5
1 files changed, 5 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e6b0fefa..50a0a142 100644
--- a/configure.in
+++ b/configure.in
@@ -1176,6 +1176,11 @@ if test "x$GCC" = "xyes"; then
esac
case " $CFLAGS " in
+ *[\ \ ]-Wno-address[\ \ ]*) ;;
+ *) CFLAGS="$CFLAGS -Wno-address" ;;
+ esac
+
+ case " $CFLAGS " in
*[\ \ ]-Wfloat-equal[\ \ ]*) ;;
*) if cc_supports_flag -Wfloat-equal; then
CFLAGS="$CFLAGS -Wfloat-equal"