summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac40
1 files changed, 40 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..28e5158
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,40 @@
+AC_PREREQ([2.68])
+AC_INIT([db-manager],[0.0.1],[william.douglas@intel.com])
+AM_INIT_AUTOMAKE([foreign -Wall -Werror])
+AC_CONFIG_FILES([Makefile src/Makefile])
+AC_CONFIG_SRCDIR([src/db-manager.c])
+AC_CONFIG_HEADERS([config.h])
+
+# Checks for programs.
+AC_PROG_CC
+AM_PROG_CC_C_O
+AC_PROG_INSTALL
+
+# PkgConfig tests
+PKG_CHECK_MODULES([libxml2], [libxml-2.0])
+PKG_CHECK_MODULES([sqlite3], [sqlite3])
+
+# Checks for header files.
+AC_CHECK_HEADERS([stdio.h assert.h sys/types.h sys/stat.h dirent.h signal.h errno.h sched.h fcntl.h stdlib.h string.h sys/time.h syslog.h unistd.h asm/unistd.h attr/xattr.h], , [AC_MSG_ERROR([UNABLE TO FIND HEADER])])
+
+# Checks for typedefs, structures, and compiler characteristics.
+AC_TYPE_SIZE_T
+AC_TYPE_SSIZE_T
+
+# Checks for library functions.
+AC_FUNC_MALLOC
+
+AC_OUTPUT
+
+AC_MSG_RESULT([
+ db-manager $VERSION
+ ========
+
+ prefix: ${prefix}
+ exec_prefix: ${exec_prefix}
+ bindir: ${bindir}
+
+ compiler: ${CC}
+ cflags: ${CFLAGS}
+ ldflags: ${LDFLAGS}
+])