summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac10
1 files changed, 5 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index bc9933d72..6407bea9f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -162,18 +162,18 @@ int main()
time_t now = time ((time_t *) 0);
int hour_GMT0, hour_unset;
if (putenv ("TZ=GMT0") != 0)
- exit (1);
+ return 1;
hour_GMT0 = localtime (&now)->tm_hour;
unset_TZ ();
hour_unset = localtime (&now)->tm_hour;
if (putenv ("TZ=PST8") != 0)
- exit (1);
+ return 1;
if (localtime (&now)->tm_hour == hour_GMT0)
- exit (1);
+ return 1;
unset_TZ ();
if (localtime (&now)->tm_hour != hour_unset)
- exit (1);
- exit (0);
+ return 1;
+ return 0;
}]])],
[utils_cv_localtime_cache=no],
[utils_cv_localtime_cache=yes],