summaryrefslogtreecommitdiff
path: root/tests/src/Interop/COM/NativeClients/DefaultInterfaces/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'tests/src/Interop/COM/NativeClients/DefaultInterfaces/CMakeLists.txt')
-rw-r--r--tests/src/Interop/COM/NativeClients/DefaultInterfaces/CMakeLists.txt19
1 files changed, 19 insertions, 0 deletions
diff --git a/tests/src/Interop/COM/NativeClients/DefaultInterfaces/CMakeLists.txt b/tests/src/Interop/COM/NativeClients/DefaultInterfaces/CMakeLists.txt
new file mode 100644
index 0000000000..e1448218f0
--- /dev/null
+++ b/tests/src/Interop/COM/NativeClients/DefaultInterfaces/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required (VERSION 2.6)
+
+project (COMClientDefaultInterfaces)
+include_directories( ${INC_PLATFORM_DIR} )
+include_directories( "../../ServerContracts" )
+include_directories( "../../NativeServer" )
+set(SOURCES
+ DefaultInterfacesTests.cpp
+ App.manifest)
+
+# add the executable
+add_executable (COMClientDefaultInterfaces ${SOURCES})
+target_link_libraries(COMClientDefaultInterfaces ${LINK_LIBRARIES_ADDITIONAL})
+
+# Copy CoreShim manifest to project output
+file(GENERATE OUTPUT ${CMAKE_CURRENT_BINARY_DIR}/$<CONFIG>/CoreShim.X.manifest INPUT ${CMAKE_CURRENT_SOURCE_DIR}/CoreShim.X.manifest)
+
+# add the install targets
+install (TARGETS COMClientDefaultInterfaces DESTINATION bin)