summaryrefslogtreecommitdiff
path: root/src/zap/crossgen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/zap/crossgen/CMakeLists.txt')
-rw-r--r--src/zap/crossgen/CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/src/zap/crossgen/CMakeLists.txt b/src/zap/crossgen/CMakeLists.txt
index 8cc6b38ad3..3d6ab23f1e 100644
--- a/src/zap/crossgen/CMakeLists.txt
+++ b/src/zap/crossgen/CMakeLists.txt
@@ -26,3 +26,6 @@ endif (FEATURE_READYTORUN)
add_precompiled_header(common.h ../common.cpp ZAP_SOURCES)
add_library_clr(corzap_crossgen STATIC ${ZAP_SOURCES})
+if(FEATURE_MERGE_JIT_AND_ENGINE)
+ target_link_libraries(corzap_crossgen clrjit_crossgen)
+endif(FEATURE_MERGE_JIT_AND_ENGINE)