summaryrefslogtreecommitdiff
path: root/src/vm/wks/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vm/wks/CMakeLists.txt')
-rw-r--r--src/vm/wks/CMakeLists.txt9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/vm/wks/CMakeLists.txt b/src/vm/wks/CMakeLists.txt
index 49d45ccc2f..573ec6f0fb 100644
--- a/src/vm/wks/CMakeLists.txt
+++ b/src/vm/wks/CMakeLists.txt
@@ -1,7 +1,14 @@
+if (WIN32)
+ add_precompiled_header(common.h ../common.cpp VM_SOURCES_WKS)
+ # mscorlib.cpp does not compile with precompiled header file
+ set_source_files_properties(../mscorlib.cpp PROPERTIES COMPILE_FLAGS "/Y-")
+ # .c file cannot use cpp precompiled header
+ set_source_files_properties(../microsoft.comservices_i.c PROPERTIES COMPILE_FLAGS "/Y-")
+endif (WIN32)
+
add_library(cee_wks ${VM_SOURCES_WKS} ${VM_SOURCES_WKS_AMD64_ASM})
if (WIN32)
-
# Get the current list of definitions
get_compile_definitions(DEFINITIONS)