summaryrefslogtreecommitdiff
path: root/src/vm/crossgen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vm/crossgen/CMakeLists.txt')
-rw-r--r--src/vm/crossgen/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/vm/crossgen/CMakeLists.txt b/src/vm/crossgen/CMakeLists.txt
index c112698554..5bed67918a 100644
--- a/src/vm/crossgen/CMakeLists.txt
+++ b/src/vm/crossgen/CMakeLists.txt
@@ -65,7 +65,6 @@ set(VM_CROSSGEN_SOURCES
../pendingload.cpp
../precode.cpp
../olevariant.cpp
- ../readytoruninfo.cpp
../security.cpp
../securitypolicy.cpp
../securityattributes.cpp
@@ -98,6 +97,12 @@ set(VM_CROSSGEN_SOURCES
../crossgencompile.cpp
)
+if(FEATURE_READYTORUN)
+ list(APPEND VM_CROSSGEN_SOURCES
+ ../readytoruninfo.cpp
+ )
+endif(FEATURE_READYTORUN)
+
include_directories(BEFORE ..)
include_directories(${CLR_DIR}/src/gc)