summaryrefslogtreecommitdiff
path: root/src/vm/crossgen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vm/crossgen/CMakeLists.txt')
-rw-r--r--src/vm/crossgen/CMakeLists.txt7
1 files changed, 6 insertions, 1 deletions
diff --git a/src/vm/crossgen/CMakeLists.txt b/src/vm/crossgen/CMakeLists.txt
index c2392a2d9a..c6ef163d53 100644
--- a/src/vm/crossgen/CMakeLists.txt
+++ b/src/vm/crossgen/CMakeLists.txt
@@ -16,7 +16,6 @@ set(VM_CROSSGEN_SOURCES
../comdelegate.cpp
../codeman.cpp
../compile.cpp
- ../constrainedexecutionregion.cpp
../custommarshalerinfo.cpp
../domainfile.cpp
../baseassemblyspec.cpp
@@ -97,6 +96,12 @@ set(VM_CROSSGEN_SOURCES
../crossgencompile.cpp
)
+if(FEATURE_CER)
+ list(APPEND VM_CROSSGEN_SOURCES
+ ../constrainedexecutionregion.cpp
+ )
+endif(FEATURE_CER)
+
if(FEATURE_READYTORUN)
list(APPEND VM_CROSSGEN_SOURCES
../readytoruninfo.cpp