summaryrefslogtreecommitdiff
path: root/src/vm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/vm/CMakeLists.txt')
-rw-r--r--src/vm/CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/src/vm/CMakeLists.txt b/src/vm/CMakeLists.txt
index 9fdddd6c26..79bd078c45 100644
--- a/src/vm/CMakeLists.txt
+++ b/src/vm/CMakeLists.txt
@@ -216,7 +216,6 @@ set(VM_SOURCES_WKS
securitydeclarative.cpp
securitydeclarativecache.cpp
securitydescriptorappdomain.cpp
- securityhostprotection.cpp
securitymeta.cpp
securitypolicy.cpp
securitytransparentassembly.cpp
@@ -294,7 +293,6 @@ list(APPEND VM_SOURCES_WKS
rcwrefcache.cpp
rtlfunctions.cpp
runtimecallablewrapper.cpp
- securityprincipal.cpp
stacksampler.cpp
stdinterfaces.cpp
stdinterfaces_wrapper.cpp
@@ -432,6 +430,8 @@ elseif(CLR_CMAKE_TARGET_ARCH_I386)
set(VM_SOURCES_WKS_ARCH
${ARCH_SOURCES_DIR}/jitinterfacex86.cpp
${ARCH_SOURCES_DIR}/profiler.cpp
+ exceptionhandling.cpp
+ gcinfodecoder.cpp
)
elseif(CLR_CMAKE_TARGET_ARCH_ARM)
set(VM_SOURCES_DAC_AND_WKS_ARCH