summaryrefslogtreecommitdiff
path: root/src/unwinder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/unwinder/CMakeLists.txt')
-rw-r--r--src/unwinder/CMakeLists.txt10
1 files changed, 4 insertions, 6 deletions
diff --git a/src/unwinder/CMakeLists.txt b/src/unwinder/CMakeLists.txt
index bf1cfa2938..5cd7bae337 100644
--- a/src/unwinder/CMakeLists.txt
+++ b/src/unwinder/CMakeLists.txt
@@ -12,12 +12,10 @@ set(UNWINDER_SOURCES
)
# Include platform specific unwinder for applicable (native and cross-target) builds.
-if(NOT DEFINED CLR_CMAKE_TARGET_ARCH_I386)
- include_directories(${ARCH_SOURCES_DIR})
- list(APPEND UNWINDER_SOURCES
- ${ARCH_SOURCES_DIR}/unwinder_${ARCH_SOURCES_DIR}.cpp
- )
-endif()
+include_directories(${ARCH_SOURCES_DIR})
+list(APPEND UNWINDER_SOURCES
+ ${ARCH_SOURCES_DIR}/unwinder_${ARCH_SOURCES_DIR}.cpp
+)
convert_to_absolute_path(UNWINDER_SOURCES ${UNWINDER_SOURCES})