summaryrefslogtreecommitdiff
path: root/src/unwinder/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/unwinder/CMakeLists.txt')
-rw-r--r--src/unwinder/CMakeLists.txt23
1 files changed, 3 insertions, 20 deletions
diff --git a/src/unwinder/CMakeLists.txt b/src/unwinder/CMakeLists.txt
index 3f81ebcccc..5ddbf42a37 100644
--- a/src/unwinder/CMakeLists.txt
+++ b/src/unwinder/CMakeLists.txt
@@ -11,28 +11,11 @@ set(UNWINDER_SOURCES
unwinder.cpp
)
-if(CLR_CMAKE_PLATFORM_ARCH_AMD64)
- include_directories(amd64)
-
+if(NOT DEFINED CLR_CMAKE_PLATFORM_ARCH_I386)
+ include_directories(${ARCH_SOURCES_DIR})
list(APPEND UNWINDER_SOURCES
- amd64/unwinder_amd64.cpp
+ ${ARCH_SOURCES_DIR}/unwinder_${ARCH_SOURCES_DIR}.cpp
)
-elseif(CLR_CMAKE_PLATFORM_ARCH_I386)
-# nothing needed for x86
-elseif(CLR_CMAKE_PLATFORM_ARCH_ARM)
- include_directories(arm)
-
- list(APPEND UNWINDER_SOURCES
- arm/unwinder_arm.cpp
- )
-elseif(CLR_CMAKE_PLATFORM_ARCH_ARM64)
- include_directories(arm64)
-
- list(APPEND UNWINDER_SOURCES
- arm64/unwinder_arm64.cpp
- )
-else()
- clr_unknown_arch()
endif()
convert_to_absolute_path(UNWINDER_SOURCES ${UNWINDER_SOURCES})