summaryrefslogtreecommitdiff
path: root/src/strongname/api/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/strongname/api/CMakeLists.txt')
-rw-r--r--src/strongname/api/CMakeLists.txt26
1 files changed, 26 insertions, 0 deletions
diff --git a/src/strongname/api/CMakeLists.txt b/src/strongname/api/CMakeLists.txt
new file mode 100644
index 0000000000..1eeed75267
--- /dev/null
+++ b/src/strongname/api/CMakeLists.txt
@@ -0,0 +1,26 @@
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+#this will again add vm to include directories. However, this will add vm to be the first include folder.
+#This is required because util.hpp is also present in ildasm folder and so due to ordering wrong util.hpp
+#is pickedup.
+include_directories(BEFORE ${VM_DIR})
+
+include_directories(${VM_DIR}/${ARCH_SOURCES_DIR})
+include_directories(${CLR_DIR}/src/md/compiler)
+
+add_definitions(-DSTRONGNAME_IN_VM -DSNAPI_INTERNAL)
+
+set(STRONGNAME_SOURCES
+ strongname.cpp
+ strongnamecoreclr.cpp
+ strongnameinternal.cpp
+)
+
+convert_to_absolute_path(STRONGNAME_SOURCES ${STRONGNAME_SOURCES})
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+add_subdirectory(dac)
+add_subdirectory(wks) \ No newline at end of file