summaryrefslogtreecommitdiff
path: root/src/palrt/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/palrt/CMakeLists.txt')
-rw-r--r--src/palrt/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/palrt/CMakeLists.txt b/src/palrt/CMakeLists.txt
new file mode 100644
index 0000000000..231e95960f
--- /dev/null
+++ b/src/palrt/CMakeLists.txt
@@ -0,0 +1,23 @@
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+add_definitions(-DNO_CRT)
+
+set(PALRT_SOURCES
+ bstr.cpp
+ coguid.cpp
+ comem.cpp
+ decarith.cpp
+ decconv.cpp
+ guid.cpp
+ memorystream.cpp
+ path.cpp
+ urlpars.cpp
+)
+
+add_compile_options(-fPIC)
+
+add_library(palrt
+ STATIC
+ ${PALRT_SOURCES}
+)