summaryrefslogtreecommitdiff
path: root/src/pal/tests/palsuite/filemapping_memmgt/LockFile/test3/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/pal/tests/palsuite/filemapping_memmgt/LockFile/test3/CMakeLists.txt')
-rw-r--r--src/pal/tests/palsuite/filemapping_memmgt/LockFile/test3/CMakeLists.txt36
1 files changed, 36 insertions, 0 deletions
diff --git a/src/pal/tests/palsuite/filemapping_memmgt/LockFile/test3/CMakeLists.txt b/src/pal/tests/palsuite/filemapping_memmgt/LockFile/test3/CMakeLists.txt
new file mode 100644
index 0000000000..69516de69b
--- /dev/null
+++ b/src/pal/tests/palsuite/filemapping_memmgt/LockFile/test3/CMakeLists.txt
@@ -0,0 +1,36 @@
+cmake_minimum_required(VERSION 2.8.12.2)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(TESTSOURCES
+ test3.c
+)
+
+add_executable(paltest_lockfile_test3
+ ${TESTSOURCES}
+)
+
+add_dependencies(paltest_lockfile_test3 coreclrpal)
+
+target_link_libraries(paltest_lockfile_test3
+ pthread
+ m
+ coreclrpal
+)
+
+
+set(HELPERSOURCES
+ helper.c
+)
+
+add_executable(paltest_lockfile_test3_helper
+ ${HELPERSOURCES}
+)
+
+add_dependencies(paltest_lockfile_test3_helper coreclrpal)
+
+target_link_libraries(paltest_lockfile_test3_helper
+ pthread
+ m
+ coreclrpal
+)