summaryrefslogtreecommitdiff
path: root/src/pal/tests/palsuite/file_io/GetFileAttributesExW/test1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/pal/tests/palsuite/file_io/GetFileAttributesExW/test1/CMakeLists.txt')
-rw-r--r--src/pal/tests/palsuite/file_io/GetFileAttributesExW/test1/CMakeLists.txt23
1 files changed, 23 insertions, 0 deletions
diff --git a/src/pal/tests/palsuite/file_io/GetFileAttributesExW/test1/CMakeLists.txt b/src/pal/tests/palsuite/file_io/GetFileAttributesExW/test1/CMakeLists.txt
new file mode 100644
index 0000000000..2d299d82e5
--- /dev/null
+++ b/src/pal/tests/palsuite/file_io/GetFileAttributesExW/test1/CMakeLists.txt
@@ -0,0 +1,23 @@
+cmake_minimum_required(VERSION 2.8.12.2)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(SOURCES
+ test1.c
+)
+
+add_executable(paltest_getfileattributesexw_test1
+ ${SOURCES}
+)
+
+add_dependencies(paltest_getfileattributesexw_test1 coreclrpal)
+
+target_link_libraries(paltest_getfileattributesexw_test1
+ pthread
+ m
+ coreclrpal
+)
+add_subdirectory(.hidden_directory)
+add_subdirectory(normal_test_directory)
+add_subdirectory(ro_test_directory)
+