summaryrefslogtreecommitdiff
path: root/src/pal/tests/palsuite/debug_api/OutputDebugStringA/test1/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/pal/tests/palsuite/debug_api/OutputDebugStringA/test1/CMakeLists.txt')
-rw-r--r--src/pal/tests/palsuite/debug_api/OutputDebugStringA/test1/CMakeLists.txt38
1 files changed, 38 insertions, 0 deletions
diff --git a/src/pal/tests/palsuite/debug_api/OutputDebugStringA/test1/CMakeLists.txt b/src/pal/tests/palsuite/debug_api/OutputDebugStringA/test1/CMakeLists.txt
new file mode 100644
index 0000000000..5bc7fdb6e9
--- /dev/null
+++ b/src/pal/tests/palsuite/debug_api/OutputDebugStringA/test1/CMakeLists.txt
@@ -0,0 +1,38 @@
+cmake_minimum_required(VERSION 2.8.12.2)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(TESTSOURCES
+ test1.c
+)
+
+add_executable(paltest_outputdebugstringa_test1
+ ${TESTSOURCES}
+)
+
+add_dependencies(paltest_outputdebugstringa_test1 coreclrpal)
+
+target_link_libraries(paltest_outputdebugstringa_test1
+ pthread
+ m
+ coreclrpal
+)
+
+
+set(HELPERSOURCES
+ helper.c
+)
+
+add_executable(paltest_outputdebugstringa_test1_helper
+ ${HELPERSOURCES}
+)
+
+add_dependencies(paltest_outputdebugstringa_test1_helper coreclrpal)
+
+target_link_libraries(paltest_outputdebugstringa_test1_helper
+ pthread
+ m
+ coreclrpal
+)
+
+