summaryrefslogtreecommitdiff
path: root/src/pal/tests/palsuite/c_runtime/abs/test1
diff options
context:
space:
mode:
Diffstat (limited to 'src/pal/tests/palsuite/c_runtime/abs/test1')
-rw-r--r--src/pal/tests/palsuite/c_runtime/abs/test1/CMakeLists.txt19
-rw-r--r--src/pal/tests/palsuite/c_runtime/abs/test1/abs.c54
-rw-r--r--src/pal/tests/palsuite/c_runtime/abs/test1/testinfo.dat13
3 files changed, 86 insertions, 0 deletions
diff --git a/src/pal/tests/palsuite/c_runtime/abs/test1/CMakeLists.txt b/src/pal/tests/palsuite/c_runtime/abs/test1/CMakeLists.txt
new file mode 100644
index 0000000000..c8a8595d01
--- /dev/null
+++ b/src/pal/tests/palsuite/c_runtime/abs/test1/CMakeLists.txt
@@ -0,0 +1,19 @@
+cmake_minimum_required(VERSION 2.8.12.2)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(SOURCES
+ abs.c
+)
+
+add_executable(paltest_abs_test1
+ ${SOURCES}
+)
+
+add_dependencies(paltest_abs_test1 coreclrpal)
+
+target_link_libraries(paltest_abs_test1
+ pthread
+ m
+ coreclrpal
+)
diff --git a/src/pal/tests/palsuite/c_runtime/abs/test1/abs.c b/src/pal/tests/palsuite/c_runtime/abs/test1/abs.c
new file mode 100644
index 0000000000..233a5dcb30
--- /dev/null
+++ b/src/pal/tests/palsuite/c_runtime/abs/test1/abs.c
@@ -0,0 +1,54 @@
+// Licensed to the .NET Foundation under one or more agreements.
+// The .NET Foundation licenses this file to you under the MIT license.
+// See the LICENSE file in the project root for more information.
+
+/*=====================================================================
+**
+** Source: abs.c (test 1)
+**
+** Purpose: Tests the PAL implementation of the abs function.
+**
+**
+**===================================================================*/
+
+#include <palsuite.h>
+
+struct TESTS
+{
+ int nTest;
+ int nResult;
+};
+
+int __cdecl main(int argc, char *argv[])
+{
+ int i = 0;
+ int nRc = 0;
+ struct TESTS testCase[] =
+ {
+ {0, 0},
+ {1, 1},
+ {-1, 1}
+ };
+
+
+ if (0 != PAL_Initialize(argc,argv))
+ {
+ return FAIL;
+ }
+
+ for (i = 0; i < (sizeof(testCase)/sizeof(struct TESTS)); i++)
+ {
+ nRc = abs(testCase[i].nTest);
+ if (nRc != testCase[i].nResult)
+ {
+ Fail("abs: ERROR -> abs(%d) returned %d "
+ "when it was expected to return %d \n",
+ testCase[i].nTest,
+ nRc,
+ testCase[i].nResult);
+ }
+ }
+
+ PAL_Terminate();
+ return PASS;
+}
diff --git a/src/pal/tests/palsuite/c_runtime/abs/test1/testinfo.dat b/src/pal/tests/palsuite/c_runtime/abs/test1/testinfo.dat
new file mode 100644
index 0000000000..98e2af21d4
--- /dev/null
+++ b/src/pal/tests/palsuite/c_runtime/abs/test1/testinfo.dat
@@ -0,0 +1,13 @@
+# Licensed to the .NET Foundation under one or more agreements.
+# The .NET Foundation licenses this file to you under the MIT license.
+# See the LICENSE file in the project root for more information.
+
+Version = 1.0
+Section = C runtime
+Function = abs
+Name = test for abs (test 1)
+Type = DEFAULT
+EXE1 = abs
+Description
+= Test abs by passing a list of values and ensuring the
+= proper absolute value is returned.