summaryrefslogtreecommitdiff
path: root/src/pal/tests/palsuite/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/pal/tests/palsuite/CMakeLists.txt')
-rw-r--r--src/pal/tests/palsuite/CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/src/pal/tests/palsuite/CMakeLists.txt b/src/pal/tests/palsuite/CMakeLists.txt
index 6f36025d1a..38b8ed0459 100644
--- a/src/pal/tests/palsuite/CMakeLists.txt
+++ b/src/pal/tests/palsuite/CMakeLists.txt
@@ -14,8 +14,15 @@ endif()
list(APPEND COMMON_TEST_LIBRARIES coreclrpal)
-add_compile_options(-Wno-incompatible-pointer-types-discards-qualifiers)
-add_compile_options(-Wno-int-to-void-pointer-cast)
+if (CMAKE_CXX_COMPILER_ID STREQUAL "Clang")
+ add_compile_options(-Wno-incompatible-pointer-types-discards-qualifiers)
+ add_compile_options(-Wno-int-to-void-pointer-cast)
+elseif (CMAKE_CXX_COMPILER_ID STREQUAL "GNU")
+ add_compile_options(-Wno-sign-compare)
+ add_compile_options(-Wno-narrowing)
+ SET(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -fpermissive" )
+ add_compile_options(-Wno-int-to-pointer-cast)
+endif()
# TODO: make these tests compile
# add_subdirectory(composite)