summaryrefslogtreecommitdiff
path: root/src/md/runtime/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/md/runtime/CMakeLists.txt')
-rw-r--r--src/md/runtime/CMakeLists.txt24
1 files changed, 24 insertions, 0 deletions
diff --git a/src/md/runtime/CMakeLists.txt b/src/md/runtime/CMakeLists.txt
new file mode 100644
index 0000000000..aa85611215
--- /dev/null
+++ b/src/md/runtime/CMakeLists.txt
@@ -0,0 +1,24 @@
+add_definitions(-DNO_COR)
+
+set(MDRUNTIME_SOURCES
+ mdcolumndescriptors.cpp
+ liteweightstgdb.cpp
+ mdfileformat.cpp
+ metamodel.cpp
+ metamodelro.cpp
+ recordpool.cpp
+ mdinternaldisp.cpp
+ mdinternalro.cpp
+)
+
+convert_to_absolute_path(MDRUNTIME_SOURCES ${MDRUNTIME_SOURCES})
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+add_subdirectory(dac)
+add_subdirectory(wks)
+if(WIN32)
+ add_subdirectory(dbi)
+endif(WIN32) \ No newline at end of file