summaryrefslogtreecommitdiff
path: root/src/md/hotdata/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/md/hotdata/CMakeLists.txt')
-rw-r--r--src/md/hotdata/CMakeLists.txt21
1 files changed, 21 insertions, 0 deletions
diff --git a/src/md/hotdata/CMakeLists.txt b/src/md/hotdata/CMakeLists.txt
new file mode 100644
index 0000000000..199edaa40e
--- /dev/null
+++ b/src/md/hotdata/CMakeLists.txt
@@ -0,0 +1,21 @@
+
+set(MDHOTDATA_SOURCES
+ hotmetadata.cpp
+ hottable.cpp
+ hotheapsdirectoryiterator.cpp
+ hotheap.cpp
+ hotheapwriter.cpp
+)
+
+convert_to_absolute_path(MDHOTDATA_SOURCES ${MDHOTDATA_SOURCES})
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+add_subdirectory(dac)
+add_subdirectory(full)
+add_subdirectory(crossgen)
+if(WIN32)
+ add_subdirectory(full-staticcrt)
+endif(WIN32)