summaryrefslogtreecommitdiff
path: root/src/md/enc/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/md/enc/CMakeLists.txt')
-rw-r--r--src/md/enc/CMakeLists.txt22
1 files changed, 22 insertions, 0 deletions
diff --git a/src/md/enc/CMakeLists.txt b/src/md/enc/CMakeLists.txt
new file mode 100644
index 0000000000..8e388f526e
--- /dev/null
+++ b/src/md/enc/CMakeLists.txt
@@ -0,0 +1,22 @@
+set(MDRUNTIMERW_SOURCES
+ liteweightstgdbrw.cpp
+ metamodelenc.cpp
+ metamodelrw.cpp
+ peparse.cpp
+ rwutil.cpp
+ stgio.cpp
+ stgtiggerstorage.cpp
+ stgtiggerstream.cpp
+ mdinternalrw.cpp
+)
+
+convert_to_absolute_path(MDRUNTIMERW_SOURCES ${MDRUNTIMERW_SOURCES})
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+add_subdirectory(dac)
+add_subdirectory(wks)
+add_subdirectory(dbi)
+add_subdirectory(crossgen)