summaryrefslogtreecommitdiff
path: root/src/md/datasource/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/md/datasource/CMakeLists.txt')
-rw-r--r--src/md/datasource/CMakeLists.txt15
1 files changed, 15 insertions, 0 deletions
diff --git a/src/md/datasource/CMakeLists.txt b/src/md/datasource/CMakeLists.txt
new file mode 100644
index 0000000000..6657c0615a
--- /dev/null
+++ b/src/md/datasource/CMakeLists.txt
@@ -0,0 +1,15 @@
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+set(MDDATASOURCE_SOURCES
+ api.cpp
+ datatargetreader.cpp
+ remotemdinternalrwsource.cpp
+ targettypes.cpp
+)
+
+convert_to_absolute_path(MDDATASOURCE_SOURCES ${MDDATASOURCE_SOURCES})
+
+add_subdirectory(dbi)
+