summaryrefslogtreecommitdiff
path: root/src/jit/protojit/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/jit/protojit/CMakeLists.txt')
-rw-r--r--src/jit/protojit/CMakeLists.txt8
1 files changed, 7 insertions, 1 deletions
diff --git a/src/jit/protojit/CMakeLists.txt b/src/jit/protojit/CMakeLists.txt
index e3cc769ba0..91c69e9a83 100644
--- a/src/jit/protojit/CMakeLists.txt
+++ b/src/jit/protojit/CMakeLists.txt
@@ -3,8 +3,13 @@ project(protojit)
add_definitions(-DALT_JIT)
add_definitions(-DFEATURE_NO_HOST)
add_definitions(-DSELF_NO_HOST)
+add_definitions(-DFEATURE_READYTORUN_COMPILER)
remove_definitions(-DFEATURE_MERGE_JIT_AND_ENGINE)
+if(WIN32)
+ add_definitions(-DFX_VER_INTERNALNAME_STR=protojit.dll)
+endif(WIN32)
+
add_library_clr(protojit
SHARED
${SHARED_LIB_SOURCES}
@@ -28,7 +33,8 @@ if(CLR_CMAKE_PLATFORM_UNIX)
)
else()
list(APPEND RYUJIT_LINK_LIBRARIES
- msvcrt.lib
+ ${STATIC_MT_CRT_LIB}
+ ${STATIC_MT_VCRT_LIB}
kernel32.lib
advapi32.lib
ole32.lib