summaryrefslogtreecommitdiff
path: root/src/jit/crossgen/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/jit/crossgen/CMakeLists.txt')
-rw-r--r--src/jit/crossgen/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/jit/crossgen/CMakeLists.txt b/src/jit/crossgen/CMakeLists.txt
new file mode 100644
index 0000000000..f79d9e72ce
--- /dev/null
+++ b/src/jit/crossgen/CMakeLists.txt
@@ -0,0 +1,7 @@
+include(${CLR_DIR}/crossgen.cmake)
+
+if(CLR_CMAKE_TARGET_ARCH_I386 OR CLR_CMAKE_TARGET_ARCH_ARM)
+ add_definitions(-DLEGACY_BACKEND)
+endif()
+
+add_library_clr(${JIT_BASE_NAME}_crossgen ${SOURCES})