summaryrefslogtreecommitdiff
path: root/src/ipcman/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ipcman/CMakeLists.txt')
-rw-r--r--src/ipcman/CMakeLists.txt14
1 files changed, 14 insertions, 0 deletions
diff --git a/src/ipcman/CMakeLists.txt b/src/ipcman/CMakeLists.txt
new file mode 100644
index 0000000000..6213fc462c
--- /dev/null
+++ b/src/ipcman/CMakeLists.txt
@@ -0,0 +1,14 @@
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+add_definitions(-DFEATURE_NO_HOST)
+
+set(IPCMAN_SOURCES
+ ipcsharedsrc.cpp
+ ipcreaderimpl.cpp
+ ipcwriterimpl.cpp
+ ipcfunccallimpl.cpp
+)
+
+convert_to_absolute_path(IPCMAN_SOURCES ${IPCMAN_SOURCES})
+
+add_subdirectory(ipcman-staticcrt)