summaryrefslogtreecommitdiff
path: root/src/ildasm/rcdll/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ildasm/rcdll/CMakeLists.txt')
-rw-r--r--src/ildasm/rcdll/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/ildasm/rcdll/CMakeLists.txt b/src/ildasm/rcdll/CMakeLists.txt
new file mode 100644
index 0000000000..5fb49daedc
--- /dev/null
+++ b/src/ildasm/rcdll/CMakeLists.txt
@@ -0,0 +1,27 @@
+project(ildasmrc)
+
+add_definitions(-DUNICODE)
+add_definitions(-D_UNICODE)
+add_definitions(-D_FEATURE_NO_HOST)
+add_definitions(-D__ILDASM__)
+
+add_definitions(-DFEATURE_CORECLR)
+add_definitions(-DFX_VFT=VFT_DLL)
+
+add_definitions(-DFX_VER_INTERNALNAME_STR=ildasmrc.dll)
+
+set(ILDASM_RESOURCES
+ ../dasm.rc
+)
+
+add_library_clr(ildasmrc
+ SHARED
+ ${ILDASM_RESOURCES}
+)
+
+target_link_libraries(ildasmrc
+ ${STATIC_MT_CRT_LIB}
+ ${STATIC_MT_VCRT_LIB}
+)
+
+install_clr (ildasmrc) \ No newline at end of file