summaryrefslogtreecommitdiff
path: root/src/ilasm/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/ilasm/CMakeLists.txt')
-rw-r--r--src/ilasm/CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/src/ilasm/CMakeLists.txt b/src/ilasm/CMakeLists.txt
index 6117030dcc..cf983797dc 100644
--- a/src/ilasm/CMakeLists.txt
+++ b/src/ilasm/CMakeLists.txt
@@ -62,6 +62,8 @@ _add_executable(ilasm
${ILASM_RESOURCES}
)
+set_target_properties(ilasm PROPERTIES LINK_FLAGS -pie)
+
set(ILASM_LINK_LIBRARIES
utilcodestaticnohost
mscorpe