summaryrefslogtreecommitdiff
path: root/src/gcinfo/gcinfo_arm64/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gcinfo/gcinfo_arm64/CMakeLists.txt')
-rw-r--r--src/gcinfo/gcinfo_arm64/CMakeLists.txt7
1 files changed, 7 insertions, 0 deletions
diff --git a/src/gcinfo/gcinfo_arm64/CMakeLists.txt b/src/gcinfo/gcinfo_arm64/CMakeLists.txt
new file mode 100644
index 0000000000..116ed7c1d6
--- /dev/null
+++ b/src/gcinfo/gcinfo_arm64/CMakeLists.txt
@@ -0,0 +1,7 @@
+remove_definitions(-D_TARGET_AMD64_=1)
+add_definitions(-D_TARGET_ARM64_)
+
+add_library_clr(gcinfo_arm64
+ STATIC
+ ${GCINFO_SOURCES}
+)