summaryrefslogtreecommitdiff
path: root/src/gcinfo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gcinfo/CMakeLists.txt')
-rw-r--r--src/gcinfo/CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/src/gcinfo/CMakeLists.txt b/src/gcinfo/CMakeLists.txt
new file mode 100644
index 0000000000..e4730c69b3
--- /dev/null
+++ b/src/gcinfo/CMakeLists.txt
@@ -0,0 +1,27 @@
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set( GCINFO_SOURCES
+ arraylist.cpp
+ gcinfoencoder.cpp
+)
+
+
+if(CLR_CMAKE_TARGET_ARCH_I386)
+ list(APPEND GCINFO_SOURCES
+ ../gcdump/gcdump.cpp
+ ../gcdump/${ARCH_SOURCES_DIR}/gcdumpx86.cpp
+ )
+endif(CLR_CMAKE_TARGET_ARCH_I386)
+
+
+convert_to_absolute_path(GCINFO_SOURCES ${GCINFO_SOURCES})
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+add_subdirectory(lib)
+add_subdirectory(crossgen)
+
+_install (FILES gcinfoencoder.cpp
+ DESTINATION gcinfo)