summaryrefslogtreecommitdiff
path: root/src/gcinfo/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gcinfo/CMakeLists.txt')
-rw-r--r--src/gcinfo/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/gcinfo/CMakeLists.txt b/src/gcinfo/CMakeLists.txt
new file mode 100644
index 0000000000..528b9223ba
--- /dev/null
+++ b/src/gcinfo/CMakeLists.txt
@@ -0,0 +1,16 @@
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set( GCINFO_SOURCES
+ gcinfoencoder.cpp
+ dbggcinfoencoder.cpp
+)
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+add_library(gcinfo
+ STATIC
+ ${GCINFO_SOURCES}
+)