summaryrefslogtreecommitdiff
path: root/src/gc/sample/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/gc/sample/CMakeLists.txt')
-rw-r--r--src/gc/sample/CMakeLists.txt34
1 files changed, 34 insertions, 0 deletions
diff --git a/src/gc/sample/CMakeLists.txt b/src/gc/sample/CMakeLists.txt
new file mode 100644
index 0000000000..572fba371f
--- /dev/null
+++ b/src/gc/sample/CMakeLists.txt
@@ -0,0 +1,34 @@
+project(clrgcsample)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+include_directories(..)
+include_directories(../env)
+
+set(SOURCES
+ GCSample.cpp
+ gcenv.ee.cpp
+ ../gccommon.cpp
+ ../gceewks.cpp
+ ../gcscan.cpp
+ ../gcwks.cpp
+ ../handletable.cpp
+ ../handletablecache.cpp
+ ../handletablecore.cpp
+ ../handletablescan.cpp
+ ../objecthandle.cpp
+ ../softwarewritewatch.cpp
+)
+
+if(WIN32)
+ list(APPEND SOURCES
+ gcenv.windows.cpp)
+ add_definitions(-DUNICODE=1)
+else()
+ list(APPEND SOURCES
+ gcenv.unix.cpp)
+endif()
+
+_add_executable(gcsample
+ ${SOURCES}
+)