summaryrefslogtreecommitdiff
path: root/src/debug/ildbsymlib/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/debug/ildbsymlib/CMakeLists.txt')
-rw-r--r--src/debug/ildbsymlib/CMakeLists.txt18
1 files changed, 18 insertions, 0 deletions
diff --git a/src/debug/ildbsymlib/CMakeLists.txt b/src/debug/ildbsymlib/CMakeLists.txt
new file mode 100644
index 0000000000..1bd1096ed6
--- /dev/null
+++ b/src/debug/ildbsymlib/CMakeLists.txt
@@ -0,0 +1,18 @@
+if(WIN32)
+ #use static crt
+ add_definitions(-MT)
+endif(WIN32)
+
+set( ILDBSYMLIB_SOURCES
+ symread.cpp
+ symbinder.cpp
+ ildbsymbols.cpp
+ symwrite.cpp
+)
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+add_library_clr(ildbsymlib ${ILDBSYMLIB_SOURCES})
+