summaryrefslogtreecommitdiff
path: root/src/debug/dbgutil/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/debug/dbgutil/CMakeLists.txt')
-rw-r--r--src/debug/dbgutil/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/debug/dbgutil/CMakeLists.txt b/src/debug/dbgutil/CMakeLists.txt
new file mode 100644
index 0000000000..1c0d49a24e
--- /dev/null
+++ b/src/debug/dbgutil/CMakeLists.txt
@@ -0,0 +1,16 @@
+if(WIN32)
+ #use static crt
+ add_definitions(-MT)
+endif(WIN32)
+
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+set(DBGUTIL_SOURCES
+ dbgutil.cpp
+)
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+add_library_clr(dbgutil STATIC ${DBGUTIL_SOURCES})