summaryrefslogtreecommitdiff
path: root/src/corefx/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/corefx/CMakeLists.txt')
-rw-r--r--src/corefx/CMakeLists.txt16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/corefx/CMakeLists.txt b/src/corefx/CMakeLists.txt
new file mode 100644
index 0000000000..5abcaa32c9
--- /dev/null
+++ b/src/corefx/CMakeLists.txt
@@ -0,0 +1,16 @@
+
+# This portion of the tree is for portions of CoreFX libraries which are (1) best
+# suited to having been implemented in native code and (2) need to be invoked from
+# mscorlib.dll. If mscorlib.dll does not use the library, the code should go in
+# the src/Native directory of dotnet/corefx.
+#
+# The libraries should disable the "lib" prefix, and use an assembly-style naming format,
+# such as System.Security.Cryptography.Native (shared across multiple System.Security.Cryptography.*
+# assemblies) or System.Diagnostics.Process.Native (a native interop library for
+# System.Diagnostics.Process.dll).
+
+remove_definitions(-D_WIN64)
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_subdirectory(System.Globalization.Native)
+endif(CLR_CMAKE_PLATFORM_UNIX)