summaryrefslogtreecommitdiff
path: root/src/coreclr/hosts/unixcoreruncommon/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/coreclr/hosts/unixcoreruncommon/CMakeLists.txt')
-rw-r--r--src/coreclr/hosts/unixcoreruncommon/CMakeLists.txt12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/coreclr/hosts/unixcoreruncommon/CMakeLists.txt b/src/coreclr/hosts/unixcoreruncommon/CMakeLists.txt
new file mode 100644
index 0000000000..a17e0a0fd6
--- /dev/null
+++ b/src/coreclr/hosts/unixcoreruncommon/CMakeLists.txt
@@ -0,0 +1,12 @@
+project(unixcoreruncommon)
+
+add_compile_options(-fPIC)
+
+_add_library(unixcoreruncommon
+ STATIC
+ coreruncommon.cpp
+)
+
+if(CLR_CMAKE_PLATFORM_LINUX)
+ target_link_libraries(unixcoreruncommon dl)
+endif(CLR_CMAKE_PLATFORM_LINUX)