summaryrefslogtreecommitdiff
path: root/src/coreclr/hosts/unixcoreconsole/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/coreclr/hosts/unixcoreconsole/CMakeLists.txt')
-rw-r--r--src/coreclr/hosts/unixcoreconsole/CMakeLists.txt9
1 files changed, 7 insertions, 2 deletions
diff --git a/src/coreclr/hosts/unixcoreconsole/CMakeLists.txt b/src/coreclr/hosts/unixcoreconsole/CMakeLists.txt
index 8988e60dcf..94587b5374 100644
--- a/src/coreclr/hosts/unixcoreconsole/CMakeLists.txt
+++ b/src/coreclr/hosts/unixcoreconsole/CMakeLists.txt
@@ -23,11 +23,16 @@ endif(NOT CMAKE_SYSTEM_NAME STREQUAL FreeBSD AND NOT CMAKE_SYSTEM_NAME STREQUAL
# pthread by the process executable ensures that all locks are initialized properly.
target_link_libraries(coreconsole
unixcoreruncommon
- pthread
)
+if(NOT CLR_CMAKE_PLATFORM_ANDROID)
+ target_link_libraries(coreconsole
+ pthread
+ )
+endif()
+
add_dependencies(coreconsole
coreclr
)
-install_clr(coreconsole) \ No newline at end of file
+install_clr(coreconsole)