summaryrefslogtreecommitdiff
path: root/src/classlibnative/bcltype/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/classlibnative/bcltype/CMakeLists.txt')
-rw-r--r--src/classlibnative/bcltype/CMakeLists.txt32
1 files changed, 32 insertions, 0 deletions
diff --git a/src/classlibnative/bcltype/CMakeLists.txt b/src/classlibnative/bcltype/CMakeLists.txt
new file mode 100644
index 0000000000..4df909ae35
--- /dev/null
+++ b/src/classlibnative/bcltype/CMakeLists.txt
@@ -0,0 +1,32 @@
+set(CMAKE_INCLUDE_CURRENT_DIR ON)
+
+if(PerfCountersSupportedBuild)
+ add_definitions(-DENABLE_PERF_COUNTERS)
+endif(PerfCountersSupportedBuild)
+
+set(BCLTYPE_SOURCES
+ arraynative.cpp
+ arrayhelpers.cpp
+ console.cpp
+ currency.cpp
+ decimal.cpp
+ windowsruntimebufferhelper.cpp
+ number.cpp
+ oavariant.cpp
+ objectnative.cpp
+ stringnative.cpp
+ stringbuffer.cpp
+ system.cpp
+ varargsnative.cpp
+ variant.cpp
+)
+
+if(CLR_CMAKE_PLATFORM_UNIX)
+ add_compile_options(-fPIC)
+endif(CLR_CMAKE_PLATFORM_UNIX)
+
+add_library_clr(bcltype
+ STATIC
+ ${BCLTYPE_SOURCES}
+)
+