summaryrefslogtreecommitdiff
path: root/src/CMakeLists.txt
diff options
context:
space:
mode:
Diffstat (limited to 'src/CMakeLists.txt')
-rw-r--r--src/CMakeLists.txt6
1 files changed, 4 insertions, 2 deletions
diff --git a/src/CMakeLists.txt b/src/CMakeLists.txt
index 35914f2f10..2822facb71 100644
--- a/src/CMakeLists.txt
+++ b/src/CMakeLists.txt
@@ -14,8 +14,10 @@ if(WIN32)
enable_language(ASM_MASM)
else(WIN32)
enable_language(ASM)
-# This prevents inclusion of standard compiler headers
-add_compile_options(-nostdinc -nostdinc++)
+# This prevents inclusion of standard C compiler headers
+add_compile_options(-nostdinc)
+# This prevents inclusion of standard C++ compiler headers
+set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -nostdinc++")
endif(WIN32)
add_subdirectory(utilcode)